BINGO! Newbie stalking compile / SCASM error....

General discussion about Scenery Design. Questions about SBuilder for Flight Simulator FS2004.
Post Reply
Mick
Posts: 59
Joined: Fri Oct 05, 2007 7:42 pm
Location: Germany

BINGO! Newbie stalking compile / SCASM error....

Post by Mick » Fri Oct 05, 2007 7:47 pm

(Own error-stalking edits at bottom)

Hello,

being new in SC design at all, I really appreciate the great (!) SBuilder after days of useless trying around with command-line-tools and other user-bugging stuff! All I wanted to do is to add a little village on the beach of Goa... almost gave up, and now I'm happy that I obviously found exactly the tool that I was looking for :-)

Just one frustrating thing: From my simple test-sceneries I can't get out proper BGL files obviously.

1. E.g. I followed the manual exactly for creating a mesh (from SRTM data), got 6 BGLs (in my case to copy into ..\addon scenery\goacoast\scenery without sister texture folder) but don't see anything of the peaks in FS.
2. In a second test I tried to just put a lake (polygon) and some simple objects in their places, get two .scm files in my "work" directory but still no BGL.

Does anyone have an idea what might have happened? I'm rather sure having followed the instructions quite precisely, but being a newbie I also might not see some important points in the process...

Please help saving my weekend :-)
Regards from Munich
Mick


1st EDIT:
Though the screenshots some users put here of their directories, I found that between example 1 and example 2 (above) I must have deleted SCASM... [B)] reinstalling the latest version 2.96 helped making one BGL of 2 from the "GoaCoast_Empty_LWM2.scm" (one polygon / lake) file on command line. Trying the same with the objects file "GoaCoast_Empty_OB1.scm" (containing 5 objects only) resulted in 3 runtime errors of SCASM.EXE:
"unknown software exception" (0xc0000091) at 0x0041226c, the same at 0x0041226c (again???) and "unknown software exception" (0xc0000027) at 0x7c80de9c

Now let me see if the lake is visible in FS9... [:I]

2nd EDIT: BINGO - The lake is visible, in a slightly different position than expected, but... I'm on my way [8D] Still I'd be extremely thankful if anyone could help me further with the scasm problem. Maybe it's as easy as just using an older version or other stupid traps?

3rd: FINALLY found that (typical newbies?) trap [:D][:D][:D]
The SCASM error messages lead me to the point, when I remembered that in SOME (was it the SBuilders?) Manual I had read it would be NECESSARY TO CHANGE THE DECIMAL INDICATOR FROM "," TO "."! After changing it, I have a beautifully running AND compiling SBuilder [;)] with visible results ... still in slightly wrong places, but this should be a cakewalk compared to before [8D], even if it was as simple and stupid as you wouldn't have guessed.

__________________________________________________________________________________________

I hope this long self-reflection at least helps other beginners to not give up before even starting their first SBuilder project and enjoy this amazing tool as well as appreciate it the way it deserves (after first experience I have to mention this again and again )!

Cheers to all
Mick

[:)]

User avatar
Luis Sa
Posts: 1734
Joined: Sun May 18, 2003 11:17 am
Location: Portugal
Contact:

Post by Luis Sa » Sun Oct 07, 2007 3:04 pm

Hello Mike,

Welcome to the forum!

Regards,

Luis

Mick
Posts: 59
Joined: Fri Oct 05, 2007 7:42 pm
Location: Germany

Post by Mick » Mon Oct 08, 2007 1:59 pm

Hello Luis,

thank you for the kind welcome... I hope you could smile a bit about the mental depression I described on the way to my first little (little little) scenery [:D] By the way: SB starts with the regular "," delimiter - wouldn't it be the easiest Job for a prog to switch it to "." when needed (e.g. compiling) and switch it back afterwards??

Let me personally express my gratitude for the great tool you supply for the FS community, in which I'm really a beginner (but an excited one) in FS as well as in scenery design!

Meanwhile I even saw my Mesh working, but still there are many open questions, of course (although I honestly have the manual online all the time). I hope I don't have to bother you too often. It's a bit difficult to find all the answers by oneself, since many of the information on the internet seems to be outdated i.e. the problems solved through updates etc.

One first question: Is it (still) true, that if I use photo scenery (tiles) all the autogen goes? Watching my results I think so, but maybe there are new techniques?

Luis, thank you for now, and I wish you a sunny and pleasent day!

Regards from Munich
Mick

User avatar
Luis Sa
Posts: 1734
Joined: Sun May 18, 2003 11:17 am
Location: Portugal
Contact:

Post by Luis Sa » Mon Oct 08, 2007 2:50 pm

Hello ,

SBuilder for FS9 makes photo scenery using VTP polys. It is diferent from using FS resample tool. The advantage is that you can anotate your tiles with your own autogen. Please check this forum to get many discussions on this one.

Kind Regards,

Luis[:)]

Post Reply