Problema com polígonos de água

This is the Forum to discuss the use of SBuilderX (version 3.10 and above). For previous versions of SBuilder please use the "SBuilder for Flight Simulator FS2004" forum.
Post Reply
josemaia
Posts: 14
Joined: Sun Sep 11, 2005 2:27 am
Location: Portugal

Problema com polígonos de água

Post by josemaia » Tue Jul 10, 2007 11:53 pm

Quando quero fazer um lago, rio, etc. e escolho as proprieades do polígono para agua, por Ex.: Hidro Default Perenial, acontece que quando volto a verificar está sempre mudado para Hidro RockSlope Perennial. O mesmo acontece se importo um ficheiro .SBX da versão anteror do SBilderX, ele converte ayutomaticamente todos os poligonos de agua para Hidro RockSlope Perennial resultando numa superfície de agua que não é lisa. Alguma solução para isso?

User avatar
Luis Sa
Posts: 1735
Joined: Sun May 18, 2003 11:17 am
Location: Portugal
Contact:

Post by Luis Sa » Wed Jul 11, 2007 10:08 pm

Olá José,

I will answer in English because this seems to be a bug. In fact I just created a polygon of type Hidro Default Perenial and then I created something else. Then I went back to see the propoerties of the first polygon and it shows Hidro RockSlope Perennial [:(!]

I will export the project and examine what causes this. If I get something, I will come back here,

Regards, Luis

User avatar
Luis Sa
Posts: 1735
Joined: Sun May 18, 2003 11:17 am
Location: Portugal
Contact:

Post by Luis Sa » Wed Jul 11, 2007 10:25 pm

Olá José,

What determines the properties of a polygon is the GUID. Polys.txt is based on Luis Tirado & Richard Ludowise modified terrain.cfg file. The GUID for the 2 types that you refer is:

guid={CB2D5672-CCBC-429B-BA43-2EA24E37EF4C}

and that explains why you set something and then see another thing. Please read the html file that comes with the modified terrain.cfg. The authors address that problem.

Regards,

Luis

josemaia
Posts: 14
Joined: Sun Sep 11, 2005 2:27 am
Location: Portugal

Post by josemaia » Fri Jul 13, 2007 9:11 pm

Obrigado pela resposta!

Só depois de levantar a questão é que reparei que isso só acontecia se fosse um poligono do tipo Hidro Default Perenial...nada que cause grandes problemas. De qualquer forma, maís uma vez obrigado por ter disponibilizado esta fantastica ferramenta.

José Maia

Post Reply