.INF edition not working

This is the Forum to discuss the use of SBuilderX (version 3.10 and above). For previous versions of SBuilder please use the "SBuilder for Flight Simulator FS2004" forum.

.INF edition not working

Postby wianfe » Thu Mar 17, 2016 10:56 pm

Hello everybody.
I wrote an .INF file to a foto real scerery with (water mask; blan mask, day and night ligh- see below) but it is not working. What am I doing wrong? Somebody can help?

[Source]
Type = MultiSource
NumberOfSources = 4

[Source1]
Type = BMP
Layer = Imagery
SourceDir = "."
SourceFile = "11.BMP_IMAG.bmp"
Variation = DAY
Channel_BlendMask = 2.0
Channel_LandWaterMask = 3.0
ulyMap = -3.08566552872146
ulxMap = -59.8974609375
xDim = 2.68220901489605E-06
yDim = 2.67827865075202E-06

[Source2]
Type = BMP
Layer = None
SourceDir = "."
SourceFile = "11.BMP_BM.bmp"
SamplingMethod = Gaussian
ulyMap = -3.08566552872146
ulxMap = -59.8974609375
xDim = 2.68220901489605E-06
yDim = 2.67827865075202E-06

[Source3]
Type = BMP
Layer = None
SourceDir = "."
SourceFile = "11.BMP_WM.bmp"
SamplingMethod = Gaussian
ulyMap = -3.08566552872146
ulxMap = -59.8974609375
xDim = 2.68220901489605E-06
yDim = 2.67827865075202E-06

[Source4]
Type = BMP
Layer = Imagery
SourceDir = "."
SourceFile = "11.BMP_LN.bmp"
Variation = Night
ulyMap = -3.08566552872146
ulxMap = -59.8974609375
xDim = 2.68220901489605E-06
yDim = 2.67827865075202E-06

[Destination]
DestDir = "."
DestBaseFileName = "11"
DestFileType = BGL
LOD = Auto
UseSourceDimensions = 1
CompressionQuality = 85
wianfe
 
Posts: 7
Joined: Wed Mar 02, 2016 5:11 pm

Re: .INF edition not working

Postby meshman » Fri Mar 18, 2016 3:38 pm

My first thought is that the choice of file names is causing a problem. But it's still early here...

Have you tried to compile inside a DOS window to see what error is showing?

The other steps would be to set things up as a single source INF file and see if it spits out a BGL. If so, start adding the other sources one at a time and see where it fails.
Lance
meshman
 
Posts: 219
Joined: Sun Jan 01, 2006 11:54 pm
Location:

Re: .INF edition not working

Postby wianfe » Fri Mar 18, 2016 7:37 pm

Hello, thanks for answer. There's no error in compilation. The problems started when I inserted the Day and night variations lines. When I take off these lines, the scenary cames back to normal but no night light scenery. I tried everything and and nothing.
wianfe
 
Posts: 7
Joined: Wed Mar 02, 2016 5:11 pm

Re: .INF edition not working

Postby luisfeliztirado » Sat Mar 19, 2016 12:39 pm

I don't know if this will have any effect, but could you try changing

Variation = DAY

to

Variation = Day


Notice the change from all Capital letters.

Best regards.
Luis
User avatar
luisfeliztirado
 
Posts: 412
Joined: Sun May 15, 2005 8:15 am
Location: Santo Domingo

Re: .INF edition not working

Postby wianfe » Sat Mar 19, 2016 4:57 pm

Hello, thanks a lot folks for help. I tryed yor suggestion Luis and apparently it worked. No more red lights in scenery. I thought tha was not possible to edit an .INF file like that. It's my firt scenery and having a lot of difficulties with water and bland mask. For example, can you give me a suggestion of how to make the water and bland mask of this part of the scenery? Please see bad the final result in files attached. Again, thanks for help. Olá Luis, talvez possamos conversar em português?
Attachments
Terrain watermask.jpg
Watermask design
Terrain blandmask.jpg
Blandmask design
Not correct final terrain.jpg
Final result
wianfe
 
Posts: 7
Joined: Wed Mar 02, 2016 5:11 pm

Re: .INF edition not working

Postby luisfeliztirado » Sun Mar 20, 2016 12:57 am

Sinto muito , não falo Português,

Pero ¡sí hablo español! :lol:

We are all very happy to help, but perhaps you could take a first look at some tutorials. To start,

"Make photo-real ground textures in FSX"

I placed this document in the Avsim library, but other web sites have added it to their collection. You should be able to find it through a simple Google search with my name.

This tutorial deals extensively with all aspects of photo-real scenery, including Water and Blend Masks. There are many illustrations showing how to get the best results.

Some of my tutorials have been translated into other languages, including Portuguese, but unfortunately I do not remember if this is one of them.

In the meantime,

- a Water Mask is a simple image where water areas are painted pure black (RGB=0,0,0) and land is painted pure white (RGB=256,256,256). As you can now understand, your Water Mask is incorrect. In fact, your Blend Mask seems to be a perfect Water Mask.

- a Blend Mask allows you to gradually merge your photo-real image with the default ground textures. Any part of the Blend Mask that is pure white will display your photo-real image. Any pure black areas will be transparent and completely reveal the underlying default ground textures with their autogen buildings and vegetation. Areas of the Blend Mask in varying shades of grey will be semi-transparent and partially display both your and the default ground.

If you have any questions, please do not hesitate to ask.

Best regards.
Luis
User avatar
luisfeliztirado
 
Posts: 412
Joined: Sun May 15, 2005 8:15 am
Location: Santo Domingo

Re: .INF edition not working

Postby wianfe » Sun Mar 20, 2016 7:49 pm

Hello Luis. Sorry, I thought you were portuguese. I do not speek spanish. Realy thanks for suggestions and I've had downloaded your tutorial before. I read and whached a lot of tutorial about Water/BlandMask. There are so many differents ways to make it. I used GIMP or Photoshop in other scenery's part and ok (see the image) but, especificly with this part of my scenery, the tecknincs are not working. An other problem, it's that I do not know yet how to fix the square or make the transition between of the limits of FSX's default terrain and my scenery (see image). Maybe you can give me a sugestion of how can I do that. I'm trying BlandMask but it's not working too. Again, thanks for your attention and help.
Attachments
WaterMask image.jpg
WaterBlandmask.jpg
wianfe
 
Posts: 7
Joined: Wed Mar 02, 2016 5:11 pm

Re: .INF edition not working

Postby luisfeliztirado » Mon Mar 21, 2016 12:56 am

1. A Water Mask must be painted black where there is water and white where there is land. The Water Mask you show in the Gimp is only painted black. Please fill the rest with pure white

2. The square is the border between the water in your photo-real image and the default water. This is why you need a Blend Mask. Make an image where pure white displays the aerial image, then towards the edges where it approaches the border with the default scenery, fill it with gray. This will be semi-transparent, displaying both your aerial image and the default ground and water. As they will be blended together, the square edges will not be visible.

Best regards.
Luis
User avatar
luisfeliztirado
 
Posts: 412
Joined: Sun May 15, 2005 8:15 am
Location: Santo Domingo

Re: .INF edition not working

Postby wianfe » Mon Mar 21, 2016 12:33 pm

Hello, Luis, many thanks for help and attention.
wianfe
 
Posts: 7
Joined: Wed Mar 02, 2016 5:11 pm


Return to SBuilderX for Flight Simulator X



Who is online

Users browsing this forum: No registered users