Compile problem

This is the Forum to discuss the use of SBuilderX (version 3.10 and above). For previous versions of SBuilder please use the "SBuilder for Flight Simulator FS2004" forum.

Compile problem

Postby mouhcinedu92 » Fri Apr 22, 2016 7:27 pm

Hi everyone !
I'm work on a a photoreal scenery .
I'v modified .bmp on SbuilderX313/Tools/Work
But when I compile this modified .bmp I have a problem !
"BMP header is corrupt."
"Unable to open data source C:/Programm...work/"
Failed to create data source .
Attachments
10304505_880292398678189_6757078618834381711_n.jpg
mouhcinedu92
 
Posts: 8
Joined: Fri Apr 22, 2016 7:16 pm

Re: Compile problem

Postby luisfeliztirado » Sat Apr 23, 2016 12:46 pm

Perhaps the image editing tool you use is not saving the file correctly or in a modified format. Please provide more details.

Best regards.
Luis
User avatar
luisfeliztirado
 
Posts: 432
Joined: Sun May 15, 2005 8:15 am
Location: Santo Domingo

Re: Compile problem

Postby mouhcinedu92 » Sat Apr 23, 2016 8:05 pm

I just use GIMP and "export as image" in a my document and copy the file in my document to Sbuilder Tools/Works . It's a BMP file I just ramplace the original .bmp to the modified .
mouhcinedu92
 
Posts: 8
Joined: Fri Apr 22, 2016 7:16 pm

Re: Compile problem

Postby luisfeliztirado » Sun Apr 24, 2016 1:08 am

If you try to compile with the original image, do you get the same error?

Best regards.
Luis
User avatar
luisfeliztirado
 
Posts: 432
Joined: Sun May 15, 2005 8:15 am
Location: Santo Domingo

Re: Compile problem

Postby mouhcinedu92 » Sun Apr 24, 2016 3:16 pm

No I'dont get this error with the original file .
mouhcinedu92
 
Posts: 8
Joined: Fri Apr 22, 2016 7:16 pm

Re: Compile problem

Postby mouhcinedu92 » Sun Apr 24, 2016 6:26 pm

But the name of original and modified is the same i just ramplace it by the modified
mouhcinedu92
 
Posts: 8
Joined: Fri Apr 22, 2016 7:16 pm

Re: Compile problem

Postby mouhcinedu92 » Mon Apr 25, 2016 1:15 pm

I have the same .txt file for the modified file and original file .
I use the .txt file for the modified file .
Attachments
10675617_915806131803806_14895688401084431_n.jpg
mouhcinedu92
 
Posts: 8
Joined: Fri Apr 22, 2016 7:16 pm

Re: Compile problem

Postby luisfeliztirado » Mon Apr 25, 2016 3:07 pm

Clearly, compilation is not the problem. The GIMP seems to be changing the file in some way.

When exporting an image, aren't there some options available? Please make sure that the bitmap is not being compressed.

Best regards.
Luis
User avatar
luisfeliztirado
 
Posts: 432
Joined: Sun May 15, 2005 8:15 am
Location: Santo Domingo

Re: Compile problem

Postby mouhcinedu92 » Mon Apr 25, 2016 5:27 pm

In the propriety the original file and the modified is the same BUT the original file is 140 Mo and the modified is 105 Mo .
mouhcinedu92
 
Posts: 8
Joined: Fri Apr 22, 2016 7:16 pm

Re: Compile problem

Postby mouhcinedu92 » Tue Apr 26, 2016 1:32 pm

The modified file .bmp that doesn't compil at the left and on file .bmp that work good at the right (not modified by gimp).
Attachments
10407876_937866446264441_1779221976200674442_n.jpg
mouhcinedu92
 
Posts: 8
Joined: Fri Apr 22, 2016 7:16 pm

Re: Compile problem

Postby luisfeliztirado » Tue Apr 26, 2016 2:17 pm

I see that your image has 32 bit color. As far as I know, Resample will only accept 24 bit bitmaps, so you may want to check that. Perhaps you are not flattening your image before exporting it.

Perhaps you could try something different if the GIMP modified bitmap does not compile correctly.

Resample will also accept TIFF files as a source. So, you could export your modified image as a TIFF image (make sure it is not RLE compressed) and see if that will compile correctly.

You will probably have to modify the inf file and change the name of your source file, since it will be a tif, not a bmp. Also, you will have to compile manually; just make sure the source image and inf file are in the same folder as Resample, then simply drag and drop the inf file on top of Resample.

Clearly, the GIMP is somehow changing your bitmap. There are not a lot of options when exporting a file as a bitmap, essentially just color depth, but check to see that there is nothing strange there.

Oh, and you might also check to see if you have the latest version of the GIMP and its dependent files.

Best regards.
Luis
User avatar
luisfeliztirado
 
Posts: 432
Joined: Sun May 15, 2005 8:15 am
Location: Santo Domingo

Re: Compile problem

Postby mouhcinedu92 » Thu Apr 28, 2016 11:16 am

Thanks a lot Luis for your help ! I just use Paint and not Gimp and just save file .
Clearly Gimp is the problem probably because Gimp change my file !
I Will send you a picture of my scenery ! ;)
mouhcinedu92
 
Posts: 8
Joined: Fri Apr 22, 2016 7:16 pm


Return to SBuilderX for Flight Simulator X



Who is online

Users browsing this forum: No registered users

cron